Back to overview
Resolved
Website Language Update
May 11, 2026 at 5:45pm UTC
–
May 11, 2026 at 6:11pm UTC
Affected services
Website
Resolved
May 11, 2026 at 6:11pm UTC
Maintenance ended
Affected services
Created
May 11, 2026 at 5:45pm UTC
We are expanding the website's language support by adding:
- English
- French
This update is intended to make the platform more accessible and user-friendly for international visitors. During the maintenance period, some parts of the website may be temporarily unavailable or display incomplete translations while the update is being deployed.
Affected services