Dashboard/Game Panel Outage
Resolved
Jun 26, 2026 at 7:50pm UTC
The issue affecting our Dashboard/Game Panel has now been resolved, and all services are back online.
The outage was caused by an issue with our SSL certificates, which has now been fixed. We apologize for the inconvenience and appreciate your patience while we worked to restore the service.
Thank you for your understanding!
Affected services
Updated
Jun 26, 2026 at 6:40pm UTC
We have identified the root cause of the
Dashboard/Game Panel outage. Our team is currently implementing a fix to restore all services as quickly as possible.
Thank you for your continued patience and understanding. We will provide another update as soon as the issue has been fully resolved.
Affected services
Created
Jun 26, 2026 at 6:15pm UTC
Our Dashboard/Game Panel has been offline since approximately 8:10 PM. Our team is actively investigating the issue and working to restore service as quickly as possible. Thank you for your patience!
Affected services