Back to overview
Downtime

System Update

May 10, 2026 at 8:32am UTC
Affected services
Website
Panel
Node 1

Resolved
May 10, 2026 at 9:09am UTC

We updated our systems successfully and everything should be up and running again.

Created
May 10, 2026 at 8:32am UTC

Due to a security update that needs to be installed across our servers, we will be having some downtime until the update is successfully installed. We are sorry for the inconvenience.